FAQs for Maya Bridge

How do I use the Maya Bridge?

  1. Open your character in Daz Studio.
  2. Locate and open the Daz to Maya Bridge, which can be found at the top of Studio under Scripts>Bridges>Daz to Maya.
  3. Click on ‘Daz to Maya’ in the above path to run the script.
  4. In Maya, go to ‘Daz 3D’ at the top of Maya; run the script, and choose ‘Auto-Import.’
  5. That’s it!

How do I get my animation or character from Maya into Studio?

In Daz Studio:

  1. Export the character as an FBX
    • Accept the settings from the pop-up window
  2. Navigate to Scripts → Bridges → Daz to Maya
    • The files will automatically be converted and are ready to be bridged over to Maya

In Maya:

  1. Save your scene
  2. Bridge your Daz character by navigating to -Daz 3D- at the top of your screen → Daz to Maya and and select “Auto Import”
    • If you do not see -Daz 3D-, navigate to Windows → Settings/Preferences → Plugin Manager → then, check the “Loaded” and “Auto Load” boxes under the Daz to Maya Plugin section
  3. Locate the Script Editor in the lower right-hand corner and open the script window
    • Or navigate to Windows → General Editors → Script Editor 
  4. Under the MEL tab, type DAZTools (case sensitive), highlight the text, navigate to Commands and select Execute; OR, highlight the text, middle mouse click/drag to the desired shelf, and select the shortcut
  5. Under the Daz Studio Tools script window, select Rig or Re-target Skeleton, select Run on open file; OR, Chose file (and select the FBX that you exported earlier from Daz)
  6.  The plugin will now create a new rig for the selected character
  7. Animate the character
  8. Locate or re-open the DAZTools plugin and select Export Animations to DAZ
  9. Name the animation file, choose the directory for where you would like to save this file, and click Export DUF
  10. Open Daz Studio, navigate to your Content Browser, right-click “DAZ Studio Formats” and select “Add a Base Directory” to add your animation’s save location.
  11. Select the root of your character, and double click your animation.
  12. Your animation is now in Daz Studio!

What is a Bridge?

  • A Bridge is a cross-platform port that converts 3D Assets — in this case, amazing Daz content — and brings it to another software, complete with rigging, textures, and other Studio modifications.
  • The Maya Bridge is a two way connection that allows you to rig and animate in Maya and import to Studio, or build in Studio and import to Maya.

What content works in the Maya Bridge?

  • Genesis 8 & 3 Content works with the Maya Bridge.

What versions of Maya does the Daz to Maya Bridge work with?

  • The Daz to Maya Bridge works with Maya versions 2016- 2020. Supported render engines are Arnold & Vray.

What Items/Daz product features will not transfer over to Maya using the bridge?

  • Strand-based hair will have difficulty transferring.
  • Michael and Victoria 4 Content and Genesis 1 Content are not guaranteed to transfer to Maya using the bridge.  Some Genesis 2 Content may transfer, but success of transfer (including rigging, textures, etc.) will vary item by item.

I just want to import directly into Maya, do I have to use the bridge?

  • The bridge isn’t the only way you can use Daz content in Maya — your other option is to purchase Daz items that have Maya file formats, download the manual files and upload them directly into Maya. Select items in the store also include Maya files, which can be either be added directly or converted for use in your software of choice. Otherwise, you can export certain content out of Studio as .obj or .fbx files for use in third party software.

Should I pose/add textures in Studio, or in Maya?

  • It’s not recommended that you pose before exporting, as that will likely cause certain features to break. You can add textures in Studio before transfer, or continue to texture your character in Maya after the transfer.

Can I add features to my model in Maya that I already have/prefer to Studio, even if the 3D Model is in Studio?

  • This is a one-way transfer from Daz to Maya. So once you transfer your content from Studio to Maya, you can’t transfer it back; you can, however, make changes to content in Daz Studio before you transfer, and can always readjust the original asset in Studio and transfer again.
  • You can transfer your Daz content from Studio to Maya, and can always readjust the original asset in Studio and transfer again. You can also rig and animate in Maya, and then transfer that asset back to Studio to keep working on it.

I already have some assets for Maya. How can I combine the assets I have in Maya with those I have in Daz?

  • Daz products have to be transferred using the Maya Bridge. Once in Maya, you can combine any assets you already have with your Daz products.
  • You can combine assets in Maya, but the tool brings in a new scene so it needs to be imported into the original Maya scene after.
  • By exporting the assets out of the scene that was created with the bridge and then imported into the Maya scene, they can be combined. Use copy and paste if both the scenes are opened or by exporting the objects and importing in the original scene in Maya once it's open.
  • To learn how to transfer assets from Daz Studio, please see the FAQ - “How do I use the Maya Bridge”.

Is there a way to create a custom library of all my Daz/Maya assets?

  • In Daz Central you can see all compatible assets for this bridge, you are also able to use the software filter in the store to see all available assets for the Daz to Maya bridge.

Why are my object’s ‘translates’ off when I export them with the bridge?

This happens when an object has transformations that aren’t zeroed in Daz.

      Solution (1) - Click Here for Video 

    1. In the scene window, Right Click Expand > Expand All.
    2. Right Click and Select > Select all objects.
    3. Right Click and Unparent selected objects.
    4. Right Click and Select > Select all objects.
    5. Right Click and Select > Invert Selection (Ctrl + Shift + I).
    6. Delete the Selection.
    7. Right Click and Select > Select all objects.
    8. Under Parameters, go to Currently Used.
    9. Press the ‘lock’ button on all the transformations and rotations.
    10. Re-run the Bridge, and the transformations will be fixed.

        Solution (2) - For some Mac OS, or if solution (1) does not fix the problem

Sometimes Scale or Rotate will still be incorrect, but if you followed solution (1) most of the leg work has already been done.

  1. Select all objects.
  2. Go to Modify at the top left.
  3. Under Modify > Reset Transformations > Select scale and rotation.
Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request