Shop   -   Forums   -   Home   -  
Contact Daz 3D
- Submit a Help Ticket
- Submit a Bug Report

Mailing Address:
224 S 200 W #250
Salt Lake City, UT 84101
Follow

What versions of Poser are compatibile with DAZ 3D's products?

DAZ 3D strives to insure that each and every product released in the DAZ store is compatible with the most recent versions of software on the market. However, due to the ever-increasing number of products available in the online store, not all products are compatible with every version of Poser that has been created.

Currently, all products are required to be compatible with Poser 8 and higher. Poser 6 support is good, since a majority of products tested in Poser 8 will work in versions 7 and 6. The Poser 4 (also released as "Poser Artist"), Poser Pro Pack and Poser 5 versions are no longer versions that we require compatibility with in products submitted to DAZ. Technical support is provided ONLY for the versions of software that the product has been tested within and approved. There are hundreds of products that were released prior to Poser 6 being released, and the vast majority of those are compatible with Poser 4 and Poser Pro Pack and Poser 5, and for all such items we will continue to offer technical support of these products within Poser 4, Poser Pro Pack, and Poser 5.

DAZ QA currently tests all products in Poser 8.

Comments