Shop   -   Forums   -   Home   -  
Contact Daz 3D
- Submit a Help Ticket
- Submit a Bug Report

Mailing Address:
224 S 200 W #250
Salt Lake City, UT 84101
Follow

OpenGL and DAZ 3D Software

Adequate OpenGL Support is essential for DAZ Studio and other DAZ 3D Software to work properly.  OpenGL enables the software to work with the graphics card for the real time preview.  Without adequate OpenGL on your system, the application software will either warn you or simply crash.   Different Graphics Cards can provided different levels of OpenGL support.  

 This table shows the minimum and the recommended OpenGL for the four main DAZ 3D applications, including DAZ Studio 4.6+.

Application Minimum OpenGL Recommended OpenGL
     
DAZ Studio 1.3 2.1
Carrara 1.6 2.1
Bryce 1.1 1.3
Hexagon 1.1 1.3


When you move a figure or model directly in the view port in DAZ Studio and other applications, the software talks to the graphics card.  The graphics card uses OpenGL to cause the image on the display to change correctly for your actions.  This is called the real time preview (or render).  It is different from rendering to create an artistic render of the scene.  The software (DAZ Studio, Carrara, etc.) gives instructions to your graphics card in the OpenGL language and the graphics card then uses them to display to the monitor.  Here are some pointers for trouble-shooting OpenGL support based upon system type (Mac or Windows).  In addition to adequate OpenGL support, your graphics card should have sufficient graphics RAM.  The System Requirements link below should give this.

 

Mac Users

On the Mac, you must update from Apple for your MacOS.  If the update does not bring the OpenGL to the adequate version, then you won't be able to use the software.  At best, it will crash frequently.  At worst, it won't even launch.  You can check the version of OpenGL by going to About this Mac --> More Info --> System Report --> Software --> Frameworks --> OpenGL.

 

Windows Users

If your system (Graphics Card) does not have adequate OpenGL, you will need  to upgrade the OpenGL Support.  This can be as easy as updating the software driver for the graphics card, if the manufacturer has one available.  In Windows, it's best to get the software driver from the manufacturer of the graphics card, rather than from Microsoft.  ATI and Nvidia can provide good OpenGL support, but generally Nvidia is better.  Onboard cards, such as Intel Chipset graphics cards often do not have adequate OpenGL support.  We do not recommend that you use DAZ 3D Software with an Intel Chipset Graphics Card.  In addition to adequate OpenGL support, your graphics card should have sufficient graphics RAM.  The System Requirements link below should give this.

 

 

DAZ Studio System Requirements

Carrara System Requirements

Bryce System Requirements

Hexagon System Requirements

Comments